VI client Install in Disconnected Environments

Yes disconnected environments do exist! I mean completely and totally disconnected.

Well I had one of those today. My customer has a network which is completely and physically disconnected from the corporate LAN and therefore also not connected to the internet. This because of the nature of the information that is on this secluded network, that no option for anything to go in or out over the wire.

All fine an Dandy! Installed an new ESX4i machine there today. I then wanted to install the new VI client on the users PC. Pretty straight forward - or so you would think..

Opened up the web browser and pointed it to https://ESX-HOST/client/VMware-viclient.exe and ran the exe file.

Next -> Next -> Next -> skipped the host Update utility, Waited, waited, waited
and then ………… BOINK!!!!

Installation failed ……..    returned error code 1603. And of course no Vi client.

Hmmm. Maybe something was wrong with the .net Framework on the machine - checked it and all seemed to be kosher.

Tried the installation again, and guess what? Same story! Tried it on another machine - you guessed right - Same story!

I love a challenge and solving puzzles - so this was one for me :)

I unpacked the VMware-viclient.exe and received this


So you would think that the package has all the goodies it needs in order to install. Nope..

Looking into the netfx.log which was located in the %TEMP% directory i noticed that during the installation of the .Net Framework - the Installation was looking for some file on the internet and in a local path. Internet of course would not work here - remember? Disconnected network! - and local path did not have the file either.

Looked again at the folder sizes - 2.4MB seems a bit small don't you think? Microsoft offers Microsoft .NET Framework 3.0 Service Pack 1 available here - but again 2.4MB in size. So I gathered I need the redistributable package (which should include all that I need) - again Microsoft .NET Framework 3.0 Redistributable Package here (this time a 50MB file). Got both files, moved them to my USB key, and tried the installation of .Net Framework - and guess what?

Exactly the same story!!! failed installation - looking in the logs I still see that it still wanted something from the internet.

Got fed up with this and downloaded the redistributable package of Microsoft .NET Framework 3.5 Service Pack 1 from here (this time a full package of 230MB), and moved it also onto my USB key.

Fired up the installer - click click - next next, and went to get my self a cup of water (sorry don't like coffee)

5 minutes (or so) later .Net was installed.

Started the VMware-viclient.exe.

Next -> Next -> Next -> skipped the host Update utility, waited, and then ………… it went onto the next stage of installing the Visual J# 2.0 and then waited, waited, waited and it completed the installation!!(which makes me very happy :) )

Lessons learned from this episode:

  1. Microsoft should not always presume that everyone has access to the Internet.
  2. Re-distributable packages should contain everything inside - but not always is that true.
  3. VI client works flawlessly with .Net Framework 3.5 SP1
  4. Log files can be boring - but when something does not work the way it should - they will be your aid in finding out why.

Hope you enjoyed the ride!