Upgrade vCenter to 4.1 U1

I upgraded my lab to vSphere 4.1 U1 on Friday.

vCenter was simple.

A quick set of screen shots

Pre-Check 1Pre-Check 2Pre-Check 3Pre-Check 4Pre-Check 5Pre-Check 6Pre-Check All GoodPre-Check ReportPre-Check CompleteChoose DSNSQL CredentialsUpgrade DBvCenter Service CredentialsPortsJVM MemoryGoing..Going..

And I was done.

1 Small thing though. On the credentials screenshot above which is a different color, I was asked to enter credentials for the vCenter Server Service. In My lab I have the Domain Administrator account MAISHSK\Administrator and on the vCenter Server there is a local Administrator account as well.

The Service was configured to run under a the Domain Admin account as per the vSphere 4.1 Hardening Guide

vSphere Hardening Guide

After the installation - my vCenter services would not start

A quick look at the vpxd vCenter logs located at
C:\ProgramData\VMware\VMware VirtualCenter\Logs
gave me this

Logs - Wrong Credential

I looked at the Services of the vCenter server and found that the credentials to start the service were changed to .\Administrator - instead of MAISHSK\Administrator


So of course they would not start. A quick change of the credentials and all was fine

Logs - all OK

The problem arises I think - because you have no option of changing the username - only the password during the upgrade - some of the options are greyed out as you can see below.


Quick question for VMware. If you present with a screen that allows to set the credentials - why are the options greyed out? And also we are way past 2008!


And after all that I was upgraded.


Onto the vSphere hosts.