ESX 4.0 running a vSphere Lab - part 1

I started out on my quest for getting a vSphere environment up for testing of the new technologies. I already had a Beta environment running - but for those of you who did not realize our Beta serial numbers expire on June 30th, 2009 - so you will have to update your labs anyway.

I have a dedicated Blade server for this purpose, and IBM HS21 E542 CPU (Quad) with 2GB of RAM and 150GB HD. Now you might say - and rightfully so - what can you do with only 2gb of RAM?? Well nothing really - that is why I have upped the RAM on the server to 8GB so I can get some testing done.

So since this is going to be a test bed for my full migration for the production system, I wanted to get it as close as possible to what my production system will be like.

So I started off by updating all the BIOS and firmware that was available for this Blade with the
IBM ToolsCenter Bootable Media Creator tool. This tool allows you to download the most up-to-date Firmware releases, and create a bootable ISO or USB key to install them. This is extremely useful because you can download the relevant releases for many different kinds of hardware. Enable VT and the setting for the Execution bit in the BIOS and then I installed ESX4i as my base OS.

One of the things I really love about ESXi is that it takes no time to have your host up and running, From the time you turn on the computer till you get the first ESXi login screen is not more than 7 minutes - I mean isn't that great?

So on this host I installed 2 Virtual machines - ESX 4.0 full version - using the tips from Eric Gray,
I had two hosts up and running in no time. The planned version for my production environment vCenter will be Windows 2008 Server. As you all know Windows Server R2 (which will be released on Oct. 22, 2009) will be 64 bit only - and therefore our IT dept. (with my "minor" influence) has decided that all Windows 2008 Servers will only be deployed as a 64bit OS.

I installed a windows 2008 Server 64 system with Service Pack 2, added it to the domain.

A small word of warning. Windows 2008 includes UAC. This was introduced in Windows Vista, and has now become an integral part of Windows 7 and Windows 2008. These are the defaults that UAC come with after a clean install with now settings changed from Group Policy. This could in some cases wreck havoc on your installation. In my case I wanted to see what happened if it was left at the defaults, and I had no problems


The pre-requisites for installing vCenter


So I checked that all of those were met.

local_admins user_rights






The installation was done with a member of the Domain Admins group.

I then started to install vCenter. I went through the defaults (MSDE, linked mode) I got to this screen and since this was my only vCenter server - I chose the first option.


So first a small explanation as to what exactly is happening here when installing linked mode. vCenter Linked mode works on the base of ADAM (it is as if you have Active Directory - but without actually having Active Directory).

ADAM provides data storage and retrieval for directory-enabled applications, without the dependencies that are required for the Active Directory directory service. ADAM provides much of the same functionality as Active Directory, but it does not require the deployment of domains or domain controllers, and the directory schema for ADAM is completely independent of the enterprise schema you may be using in an Active Directory domain. You can run multiple instances of ADAM concurrently on a single computer, with an independently managed schema for each ADAM instance. (Active Directory Application Mode: Frequently Asked Questions)

Well in Windows 2008 this is actually called Active Directory Lightweight Directory Services and can be managed through the Server Manager console.


Is creates a System Service which listens on port 389 (LDAP)..


And as you can see below this looks very similar to a full active Directory Schema


With the vCenter up and running I added both ESX vm's into vCenter.

And there you have it, An ESX4i Host running 3 VM's


  1. ILVSPHERE-TEST (one of those VM's)
  2. ESX4-1
  3. ESX4-2

And vSphere on ESX 4.0 hosting it all


Next up on the menu - Creating the cluster and enabling HA, and VMotion.